Difficulty using site with any Mac OS Browser

Discussion in 'Fantasy Strike' started by studioque, Feb 24, 2012.

  1. studioque

    studioque New Member

    Hey, I saw the note mentioning performance issues in Chrome on Mac OSX, but just wanted to report that since the official Fantasy Strike online game has launched I've been unable to get it to work on most of my browsers in Mac OSX (been able to play on a PC).

    I'm on OSX 10.6.8

    Chrome
    17.0.963.56
    Can't load initial screens. Freezes up.

    Safari
    5.1.2
    Can't load initial screens. Freezes up.

    Firefox
    10.0.2
    Can load initial Yomi screen. Tried playing a game against AI and just freezes on a unity loading screen.

    Chrome Canary
    19.0.1051.0 canary
    This failed the first few times I tried - it seemed to only work if I was logged into my account before I hit the "Play" tab. If I tried to login after I was already in the Play section it didn't seem to work. Still no luck in the other browsers.

    I used to play on the dev server on my mac all of the time with no problems. Have you been hearing reports of this from other users or is it just me? If you need any more info to look into it more let me know.

    Thanks.
  2. sheafification

    sheafification New Member

    I can play on OS X 10.6.8 with Safari 5.1.2. For me, starting a game for the first time takes a while, but it does work.
  3. Thelo

    Thelo Administrator Staff Member

    Can you try manually updating your Unity webplayer plugin at http://unity3d.com/webplayer , then trying again? We've had a few reports of older webplayer versions not auto-updating themselves correctly on Mac OS in particular, and I updated to a newer webplayer version right before the site's launch.

    ---

    Does anyone else use Mac OS X and have similar problems?
  4. studioque

    studioque New Member

    Will-do. I have a PC at home and Mac at work so i'll get on it when i'm back in the office on Monday. Thx!
  5. EricHerboso

    EricHerboso New Member

    While the game is playable on my mac, it has been unresponsive enough to where I figured the site was still just a work in progress. Then I watched youtube videos of how it runs on other people's machines, and realized that the problem might be specific to me.

    Sometimes Puzzle Strike will seem to lock up, and the text indicating what the client expects a player to do next disappears. Often when this happens, but not always, the info boxes on the left side of the screen become nothing more than rectangular boxes of solid color. Although it looks as though the game is locked up when this happens, it still remains responsive to input. I may not see the text at the top middle saying I need to respond to their crash gem, for example, but I can see it in the chat box, and respond appropriate;y without trouble. And if I have to click a box to indicate I want to buy a wound or whatever, I have to take a guess at where the box would be if it were not invisible.

    The game is still technically playable in this state, but it really does look awful. Every aforementioned issue does go away on its own after 45 seconds or so, which is weird, but 45 seconds is a long time to wait in an online game. And if I do not need to have knowledge of info in the leftmost infoboxes, I can still issue commands without waiting the 45 seconds.

    I have done absolutely no research into why these issues are occurring, so they may or may not be associated with the fact that I'm running the game on Mac OS X 10.5.8. I'm just merely reporting my observations after watching youtube and coming to the realization that I am the only one having these problems.
  6. Thelo

    Thelo Administrator Staff Member

    Are you playing on regular Google Chrome, and if so, have you tried using Google Chrome Canary? Mac Chrome has known stability problems with the Unity webplayer, which may or may not be the source of your problems.
  7. studioque

    studioque New Member

    Alright, tested everything out one last time before I downloaded the Unity update. Got it to work in Chrome for the first time since the launch (have tried probably 4 or 5 times since launch to get it to work). Have no clue why it just randomly worked today.

    Still having the same issue with Firefox and Safari. I would login before hitting the play tab - and on Safari it would seem to log me out (i had remember me checked) while it was loading the player - it said 100% loaded but nothing showed up.

    After installing the update was able to get it to work in Safari - it took forever to load the first time, but after initial load seemed to work well. Still having the same issue with Firefox. It's freezing up when I try to start a game against the CPU (haven't attempted a quick match or any other game type yet). Screen cap uploaded.

    So after the update got it working in Chrome and Safari. Haven't actually played any real games yet on my mac since the launch but will try it out soon. Firefox issue doesn't bother me because I have it working in other browsers, but if you'd like me to test anything else out to help you troubleshoot let me know.

    Thanks!

    Attached Files:

  8. Thelo

    Thelo Administrator Staff Member

    Thanks for the report, and I'm glad you've been able to make things work out. The Mac Firefox issue is worrying, I'll keep an eye out for whatever might be causing this problem.
  9. EricHerboso

    EricHerboso New Member

    Your suggestion worked perfectly for me. What ran poorly before now runs flawlessly. I regret not being able to use my primary browser to play here, but I am much happier with how the game plays in a different browser.
  10. JWolfenator

    JWolfenator New Member

    On Firefox 12 with Mac OSX 10.6.8. When loading Unity initially, you can see the play-field until Unity finishes loading then all you see is this...
    Even reloading Unity results in the same thing... any suggestions?
    Screen shot 2012-09-24 at 12.50.39 PM.png
  11. Thelo

    Thelo Administrator Staff Member

    It looks like that old Mac Firefox bug is still present, and unfortunately I can't do much about it since it's a bug in the Mac Firefox code. In the meantime, try using another browser, such as Google Chrome (Canary has historically worked best on Mac).

    I'm sorry about the inconvenience, and will go pester the Firefox devs some more about this bug.

Share This Page